Составьте программу в паскале abc. Дано количество информации в битах. Вывести в удобной форме в более крупных единицах. (до Мб).
Пример вывода:
10240 бит = 1280 байт = 1,25 Кб = 0,0012 Мб. Прошу помогите с формулами хотябы
Ответы на вопрос
Ответил Аноним
0
var
b:real;
begin
Write('Количество информации в битах '); Read(b);
Write(b,' бит = ');
b:=b/8; Write(b,' б = ');
b:=b/1024; Write(b,' Кб = ');
b:=b/1024; Write(b,' Мб = ');
b:=b/1024; Write(b,' Гб = ');
b:=b/1024; Write(b,' Тб')
end.
Пример
Количество информации в битах 10240
10240 бит = 1280 б = 1.25 Кб = 0.001220703125 Мб = 1.19209289550781E-06 Гб = 1.16415321826935E-09 Тб
b:real;
begin
Write('Количество информации в битах '); Read(b);
Write(b,' бит = ');
b:=b/8; Write(b,' б = ');
b:=b/1024; Write(b,' Кб = ');
b:=b/1024; Write(b,' Мб = ');
b:=b/1024; Write(b,' Гб = ');
b:=b/1024; Write(b,' Тб')
end.
Пример
Количество информации в битах 10240
10240 бит = 1280 б = 1.25 Кб = 0.001220703125 Мб = 1.19209289550781E-06 Гб = 1.16415321826935E-09 Тб
Ответил petyaGavrikov
0
var b:integer;
begin
write('Введите количество бит: ');
readln(b);
write(b,' бит = ',b/8,' байт = ');
writeln(b/8/1024,' Кбайт = ',b/8/1024/1024:6:4,' Мбайт');
end.
Пример:
Введите количество бит: 10240
10240 бит = 1280 байт = 1.25 Кбайт = 0.0012 Мбайт
begin
write('Введите количество бит: ');
readln(b);
write(b,' бит = ',b/8,' байт = ');
writeln(b/8/1024,' Кбайт = ',b/8/1024/1024:6:4,' Мбайт');
end.
Пример:
Введите количество бит: 10240
10240 бит = 1280 байт = 1.25 Кбайт = 0.0012 Мбайт
Новые вопросы