Информатика, вопрос задал Аноним , 9 лет назад

Составьте программу в Паскаль с помощью while. У Малыша К банок варенья. В первый день Карлсон съел одну банку, в каждый последующий день съедая в 1,5 раза больше, чем в предыдущий. Через сколько дней варенье кончится?

Ответы на вопрос

Ответил garfild214
0
Var K, den, s_el: real;
Begin
Writeln('Введите K банок');
readln(K);
s_el:=1;
K:=K - s_el;
den:=1;

While (K>0) do
Begin
    s_el:= s_el * 1.5;
    K:=K - s_el;
    den:=den+1;
 end;

Writeln('Варенье кончится через ', den, ' дней');

readln();
end.
Новые вопросы