Составьте программу проверяющую верно ли что сумма цифр введенного целого 3х значного числа является нечетным паскаль
Ответы на вопрос
Ответил simbion0
0
var
a,sum:integer;
begin
readln(a);
sum:= a div 100 + a div 10 mod 10 + a mod 10;
if (sum mod 2 = 0) then
writeln('Сумма чисел: ',sum,' Число является четным.')
else
writeln('Сумма чисел: ',sum,' Число не является четным.');
end.
a,sum:integer;
begin
readln(a);
sum:= a div 100 + a div 10 mod 10 + a mod 10;
if (sum mod 2 = 0) then
writeln('Сумма чисел: ',sum,' Число является четным.')
else
writeln('Сумма чисел: ',sum,' Число не является четным.');
end.
Новые вопросы