География, вопрос задал Алина3345 , 9 лет назад

составьте программу, подсчитывающую количество цифр вводимого вами целого не отрицательного числа.
на абс паскале, пожалуйста

Ответы на вопрос

Ответил katyyarmolenko
0
program n_1
s:string;
writeln('Введите число положительное целое ');
readln(s);
kol-vo:=length(s);
end.
Ответил katyyarmolenko
0
var
a:longint;
kol:integer;
begin
writeln('vvedite chislo');
readln(a);
repeat
a:=a div 10;
inc(kol);
until a=0;
writeln('kolichestvo cifr=',kol);
end.
Ответил katyyarmolenko
0
лучше 2-ю программу
Ответил Алина3345
0
спасибо
Новые вопросы