Информатика, вопрос задал QWEN1337 , 7 лет назад

Составьте программу по блок схеме пж

Приложения:

Ответы на вопрос

Ответил edikgres
1

Ответ:

Поскольку не указали язык, я написал на СИ. Код на скриншоте:

upd: Добавил листинг для питона в скриншоте. Текст после СИ.

Объяснение:

#include <stdio.h>

int main () {

   int x = 0;

   scanf("%d", &x);

   int S = 0;

   int i = 1;

   while ( i <= 9) {

       S=S+ x % i;

       i = i+1;

   }

   printf("%d", S);

   return 0;

};

Питон:

x = int(input())

S = 0

i = 1

while i <= 9:

   S = S + x % i

   i = i + 1

print(S)

Приложения:

QWEN1337: можете сделать в питоне
QWEN1337: Спасибо
Новые вопросы