составьте программу печати таблицы температур по цельсию от 0 до градусов с шагом в один градус и их эквивалентов по шкале фаренгейта используя для перевода формулу tF=9tc/5+32
Ответы на вопрос
Ответил HRAshton
0
var
max, i: integer;
begin
readln(max);
for i := 0 to max do
writeln(i:3, chr(0176), 'C | ', 9 * i / 5 + 32, chr(0176), 'F');
end.
Элементарная домашка... Не знаю, прочтёт ли это кто-нибудь, но...
Считываем верхнюю границу вывода (ибо в условии с ней заминка), а затем в столбик выводим... chr() возвращает символ по коду, а 176 - код градуса
max, i: integer;
begin
readln(max);
for i := 0 to max do
writeln(i:3, chr(0176), 'C | ', 9 * i / 5 + 32, chr(0176), 'F');
end.
Элементарная домашка... Не знаю, прочтёт ли это кто-нибудь, но...
Считываем верхнюю границу вывода (ибо в условии с ней заминка), а затем в столбик выводим... chr() возвращает символ по коду, а 176 - код градуса
Ответил TanyaRomanovaLiberty
0
Это в паскале?
Ответил TanyaRomanovaLiberty
0
а все ясно
Ответил HRAshton
0
Паскаль же все изучают... Это мы в школе КуМИР гоним
Новые вопросы
Биология,
2 года назад
Другие предметы,
2 года назад
Математика,
10 лет назад
Химия,
10 лет назад
Биология,
10 лет назад