Информатика, вопрос задал vladislav7795 , 2 года назад

Составьте программу определяющую существует ли среди чисел A B C число равное числу D
Все числа идёт от вывести на экран

Ответы на вопрос

Ответил darkmath987
1

Смотри решение во вложении

Вторая программа 100% работает, проверил

Приложения:

Metradai: Программа выдаёт ошибку в паскале
darkmath987: Ок, подожди
darkmath987: Metradai, какого рода?
Metradai: Я проверял на онлайн компиляторе так что есть вероятность что он просто не читает
Metradai: Мой вариант такой
program znanija;
var a,b,c,d:integer;
begin
writeln ('Введите число А');
readln (a);
writeln ('Введите число B');
readln (b);
writeln ('Введите число С');
readln (c);
writeln ('Введите число D');
readln (d);
if a=d
then
writeln ('Число А равно числу D, и это число - ', d);

if b=d
then
writeln ('Число B равно числу D и это число - ', d);

if c=d
then writeln ('Число C равно числу D и это число - ', d);
end.
darkmath987: Добавил вторую программу, точно работает
darkmath987: И первая программа тоже работает, только writeln(a,b,c,d) лучше не писать
vladislav7795: А можешь ещё составить задачу попадает , ли число А , в промежуток (b;c) .Все числа вводятся с клавиатуры
vladislav7795: Буду очень благодарен
darkmath987: Я уже решил, вторая фотка
Новые вопросы