Информатика, вопрос задал kosmo000 , 10 лет назад

Составьте программу, определяющую остаток от деления числа А на число В. Составьте программу, заменяющую большее из двух данных чисел модулем суммы, а меньшее – модулем полуразности этих чисел.(PASCAL)

Ответы на вопрос

Ответил ElenaChe
0

1. program ostatok;

uses crt;

var a,b,ost:real;

begin

write('a= ');

readln(a);

write('b= );

readln(b);

ost:=a mod b;

write('ostatok ot delenia A na B raven ',ost);

readln;

end.

 

2. program modul;

uses crt;

var a,b,c,d: real;

begin

write('a= ');

readln(a);

write('b= );

readln(b);

c:=a-b;

if c>0 then

begin

a:=abs(a+b);

b:=abs((a-b)/2);

write('a= ',a,'b= ',b);

end

else

b:=abs(a+b);

a:=abs((b-a)/2);

write('a= ',a,'b= ',b);

end;

readln;

end.

Новые вопросы