Информатика, вопрос задал Soffi7bayard , 7 лет назад

Составьте программу, определяющую максимальное из всех вводимых вами чисел. Концом ввода чисел является введенное число 0. Для проверки подготовить код программы и результаты ее работы.

Ответы на вопрос

Ответил raf1O5
0

Код программы

program raf105;

var a,max:integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

a:=1;

while a<>0 do

begin

 readln(a);

 if a>max

   then max:= a;

end;

writeln('Максимальное число: ',max);

end.

Результаты работы программы

Вывод:

Вводите числа по очереди

чтобы закончить введите 0

Ввод:

12

1

100

99

105

104

2

3

0

Вывод:

Максимальное число: 105

Новые вопросы