Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат.
Program Frankenstein;
var
x,y,r:integer;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln(r);
If (sqr(x)+sqr(y))=r
then writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.
Почему программа всегда показывает что точка не лежит на окружности, хотя на самом деле она лежит! Где я ошибся?
Ответы на вопрос
Ответил MagAragorn
0
Var
x,y,r:integer;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln(r);
If (sqr(x)+sqr(y))=sqr(r) then
writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.
x,y,r:integer;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln(r);
If (sqr(x)+sqr(y))=sqr(r) then
writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.
Новые вопросы
Кыргыз тили,
2 года назад
Қазақ тiлi,
2 года назад
Математика,
10 лет назад
Математика,
10 лет назад
Геометрия,
10 лет назад