Информатика, вопрос задал lili1061 , 8 лет назад

Составьте программу, определяющие самых жарких 7 дней и самых холодных 7 дней прошедшего месяца, если известна среднесуточная температура за каждый день.

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(31,16,27); a.Println;
  var s:=a.Select((x,i)->(x,i)).OrderBy(x->x[0]).Select(x->x[1]+1);
  Write('Семь самых холодных дней: '); s.Take(7).Println;
  Write('Семь самых жарких дней: '); s.TakeLast(7).Println
end.

Пример
17 17 25 27 22 26 22 23 26 26 25 16 21 25 22 17 20 19 16 19 21 22 19 16 21 27 22 24 22 24 22
Семь самых холодных дней: 12 19 24 1 2 16 18
Семь самых жарких дней: 11 14 6 9 10 4 26
Новые вопросы