Информатика, вопрос задал Katrin1102 , 8 лет назад

Составьте программу одномерного массива (10 ячеек), с помощью генератора случайных чисел (диапазон от -500 до 500). Найти минимальное и максимальное, значение всего массива, найти сумму всех двузначных положительных чисел.

Очень срочно!!!!!!!!!!!

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,-500,500); a.Println;
  Writeln('min=',a.Min,', max=',a.Max,', Sп=',
      a.Where(x->x in [10..99]).Sum)
end.

Пример
475 186 243 323 -497 23 -65 -2 180 74
min=-497, max=475, Sп=97
Ответил Katrin1102
0
Спасибо
Новые вопросы