Информатика, вопрос задал marisa14 , 10 лет назад

составьте программу нахождения трёхзначного числа , куб суммы цифр которого равен ему самому

Ответы на вопрос

Ответил zaycevlad
0

var
a,b,c,n:integer;
begin
for n:=100 to 999 do
begin
a:= n div 100;
b:= n div 10 mod 10;
c:= n mod 10;
if (a+b+c)*(a+b+c)*(a+b+c)=n then writeln(n);
end;
end.

 

и в результате получаем, что это число 512

Новые вопросы