Составьте программу нахождения суммы всех положительных двузначных чисел . Пожалуйста помогите
Ответы на вопрос
Ответил estengseant
0
var i,sum,n,k: Integer;
begin
sum:=0;
Writeln('Введите кол-во чисел');
readln(n);
dec(n);
for i:=0 to n do
begin
writeln('Введите ',i+1,' число: ');
readln(k);
if k>0 then
begin
if (k>9) and (k<100) then sum:=sum+k;
end;
end;
writeln('Ответ: ',sum);
end.
begin
sum:=0;
Writeln('Введите кол-во чисел');
readln(n);
dec(n);
for i:=0 to n do
begin
writeln('Введите ',i+1,' число: ');
readln(k);
if k>0 then
begin
if (k>9) and (k<100) then sum:=sum+k;
end;
end;
writeln('Ответ: ',sum);
end.
Новые вопросы