Составьте программу нахождения предыдущего и последующего чисел от числа введённого пользователем
valgrisa:
язык программы?
Ответы на вопрос
Ответил thereisnoescape
3
num = int(input())
print("Предыдущее - ", num - 1, "\n")
print("Последующее - ", num + 1, "\n")
Ответил valgrisa
1
Ответ:
program z;
var a:integer;
begin
write('Введите целое число: ');
readln(a);
writeln ('Предыдущее число: ',a-1);
write ('Последующее число: ',a+1)
end.
Объяснение:
write - оператор вывода
read - оператор ввода
исходное число - a
чтобы найти предыдущее число уменьшим исходное число на 1 (а - 1)
чтобы найти последующее число увеличим исходное число на 1 (а + 1)
Новые вопросы