Информатика, вопрос задал mashao0 , 2 года назад

Составьте программу нахождения максимального элемента массива, в массиве две строки, 4 столбца.​


fovfabomi: язык?
mashao0: паскаль

Ответы на вопрос

Ответил fovfabomi
1

var

 a: array[1..2,1..4] of integer;

i,j,max: integer;

begin

 writeln('введите элементы массива');

 for i:=1 to 2 do

   for j:=1 to 4 do readln(a[i,j]);

 max:=a[1,1];

 for i:=1 to 2 do

   for j:=1 to 4 do

     if a[i,j]>max then max:=a[i,j];

   writeln('максимальный элемент в массиве=',max);

end.

Новые вопросы