Информатика, вопрос задал kmatachp01gzm , 8 лет назад

Составьте программу, находящую
количество делителей числа Х. Число Х введите с клавиатуры. (Pascal ABC (не net))

Ответы на вопрос

Ответил kouper243
0
Var n, i, sum: integer; //Описание переменных Begin //Начло программы writeln ('Введите число'); //Диалог с пользователем readln(n); //Считывание числа sum := n; //Присваивание сумме значение самого числа (само число - уже делитель самого себя) writeln('Делители числа:'); //Диалог с пользователем for i := 1 to n div 2 do //Цикл For от до половины n if (n mod i) = 0 then begin //Если число делится на i, то выводим write(i,' '); sum := sum + i; //К значению суммы прибавляем делитель end; //Конец условного оператора if writeln(n); //Вывод самого числа, т.к. оно тоже делитель writeln('Сумма делителей: ',sum); //Вывод суммы делителей End.
Ответил kouper243
0
чисто их кол-во?
Ответил student2544
0
abc и abc.net не очень отличаются , я тебе уже скидывал решение
Ответил kouper243
0
2 3 4 5 6 7 8 9 10 11 12 13 14 var n,i,j,k,max,maxn:integer; begin write('n='); readln(n); if n=1 then k:=1 else  begin   k:=2;//1 и само   for i:=2 to trunc(sqrt(n)) do//считаем делители до корня из числа и умножаем на 2   if n mod i=0 then inc(k,2);   if frac(sqrt(n))=0 then dec(k);//если число полный квадрат, то минус 1  end; write('Количество делителей=',k); end.
Ответил kouper243
0
попробуй
Ответил kouper243
0
цифры только убери
Ответил student2544
0
program A;var X,sum,i: integer;beginsum := 0 ;Readln(X);for i:= 1 to X doif (X  mod i = 0) then   sum := sum + 1;Writeln(sum);end.
Ответил student2544
0
теперь нормально ?
Ответил kmatachp01gzm
0
Думаю да
Ответил kmatachp01gzm
0
У меня комп не под рукой, не могу проверить((
Ответил student2544
0
обращайся на счет программ , любое напишу .
Новые вопросы