Информатика, вопрос задал blondivanvort2ozb19f , 8 лет назад

Составьте программу на языке Паскаль для решения задачи. С клавиатуры вводятся 5 действительных чисел. Найти сумму всех чисел, больше 5. И произведение всех чисел, меньше 1.

Ответы на вопрос

Ответил varanchik
0
const n =5;
var
  a: array[1..n] of integer;
  i,k,s,p:integer;
begin
s:=0;
p:=1;
for i:=1 to n do
  begin
  readln(a[i]);
  if(a[i] >= 5) then
      s:=s+a[i] else
  if (a[i] <1) then
      p:=p*a[i];
  end;
 writeln('Исходные числа');
for i:=1 to n do
    write(a[i]+ ' ');
writeln;
writeln('Сумма чисел больше 5 : ',s:2);
writeln('Произведение меньше 1 : ',p:2);
readln
end.
Новые вопросы