Информатика, вопрос задал shashanova98 , 9 лет назад

Составьте программу на языке паскаль для подсчета суммарного числа букв "е" и "о" в строковой величине

Ответы на вопрос

Ответил NikitaSklyar
0
var s:string; j,p:integer;
begin readln(s); p:=0; for j:=1 to length(s) do if(s[j]='e')or(s[j]=o)then inc(p); writeln(p); readln end.

var s:string; j,e,o:integer;
begin
readln(s); e:=0; o:=0;
for j:=1 to length(s) do begin if s[j]='e' then inc(e); if s[j]=o then inc(o);
if o > e then writeln('o'); if o < e writeln('e'); if o=e then writeln('oe'); readln
end.

Счет букв ведется для латинских строчных букв o и e.)

Новые вопросы