Составьте программу на Паскале
На вход программы поступает неизвестное количество натуральных чисел, ввод заканчивается нулём. Найти минимальное из введённых нечётных чисел
Ответы на вопрос
Ответил Arkassssha
2
var a, min:integer;
begin
writeln('Введите числа (цифра 0 - выход из программы)');
readln(a);
min:= a;
while(a <> 0) do begin
if (((a mod 2) = 1) and (min > a)) then
min:= a;
readln(a);
end;
writeln('Минимальное нечетное число: ', min);
end.
AlicesFay:
Много скобочек после If, а так все идеально, огромное тебе спасибо!
Новые вопросы
Биология,
1 год назад
Обществознание,
1 год назад
География,
1 год назад
География,
1 год назад
Физика,
7 лет назад