Составьте программу (на алгоритмическом языке Паскаль) для вычисления суммы ряда S=1/2^2+3/4^2+5/6^2+7/8^2+9/10^2+... с точностью до члена ряда, не превышающего по абсолютной величине 0,001.
Ответы на вопрос
Ответил Pauel
0
i:integer;
b, sum:real;
BEGIN
i:=0;
while (b>=0.001) do
begin
i:=i+1;
b:=i/((i+1)*(i+1));
sum:=sum+b;
end;
writeln(sum);
END.
b, sum:real;
BEGIN
i:=0;
while (b>=0.001) do
begin
i:=i+1;
b:=i/((i+1)*(i+1));
sum:=sum+b;
end;
writeln(sum);
END.
Ответил Ekzosquad
0
program sum;
uses crt;
var k: integer;
s: real;
begin
k:=1;
s:=0;
while k/sqr(k+1)>0.001 do
begin
s:=s+k/sqr(k+1);
inc(k,2);
end;
writeln('Сумма ряда = ', s:0:4);
readln
end.
uses crt;
var k: integer;
s: real;
begin
k:=1;
s:=0;
while k/sqr(k+1)>0.001 do
begin
s:=s+k/sqr(k+1);
inc(k,2);
end;
writeln('Сумма ряда = ', s:0:4);
readln
end.
Ответил Pauel
0
не вижу особой разницы
Ответил Ekzosquad
0
Введи свою программу в PascalABC.NET и увидишь ошибки.
Новые вопросы
Математика,
2 года назад
Русский язык,
2 года назад
Математика,
9 лет назад
Математика,
9 лет назад
Алгебра,
10 лет назад