Информатика, вопрос задал nikitin782 , 6 лет назад


Составьте программу, которая здоровается с вами. Спрашивает, как вас зовут. После ввода вами имени, обращается к вам по введенному вами имени и предлагает - "Давай поиграем?"
Если вы отвечаете "Нет", то пишет "Очень жаль, Я очень опечален". И программа заканчивает свою работу.
Еесли вы набираете в ответ "Да" , то программа пишет - Задумай число" и ждет пока вы не введете число.
Если введенное число находится в диапазоне от 0 до 20 включительно, то компьютер пишет: "А у меня ... далее идет число на 1 меньшее, .. я проиграл!"
Если вы вводите число больше 200 и меньше, чем -200, то компьютер пишет: "К сожалению, я с такими числами не работаю."
Во всех остальных случаях он пишет: "А у меня ... далее идет число на 1 большее, .. я выиграл!" На Паскаль за 30 БАЛЛОВ

Ответы на вопрос

Ответил mrshaxmerdenov001
1

Ответ:

program aaa;

var name, choice : string;

numb : integer;

 

 begin

   writeln('Здравствуйте, как вас зовут ? ');

   readln(name);

   writeln();

   writeln(name,' ,давай сыграем в игру?');

   writeln(' Да / Нет ');

   readln(choice);

   

   writeln();

   

   if (choice = 'Да')or (choice = 'да') then

     begin

     write('Задумай число : ');

     read(numb);

     if (numb > 0) and (numb <= 20) then

       writeln('А у меня число : ',numb - 1,' . Я проиграл')

       else if (numb > 200) or (numb < -200) then

         writeln('К сожалению, я с такими числами не работаю')

       else

         writeln('А у меня : ',numb + 1,' Я выиграл!');

       end

     else if (choice = 'Нет') or (choice = 'нет') then

     writeln('Очень жаль, я опечален');

   end.

     

Новые вопросы