Информатика, вопрос задал oreshek2222 , 2 года назад

Составьте программу, которая запрашивает показания температуры t и рисует снежинку, если t ‹ =0, или солнышко, если t › 0. (P.S. программа - PascalABC). ​

Приложения:

Ответы на вопрос

Ответил nastikots
10

Ответ:

program z1;

uses GraphABC;

var t:integer;

begin

SetWindowSize(400,400);

write('Введите показания температуры: ');

read(t);

SetPenWidth(3);

if t<=0 then

begin

SetPenColor(clBlue);

Line (150,200,200,150);

Line (200,150,250,200);

Line (250,200,200,250);

Line (200,250,150,200);

FloodFill(200,200,clSkyBlue);

Line (100,200,300,200);

Line (200,100,200,300);

Line (100,100,300,300);

Line (100,300,300,100)

end

else

begin

SetPenColor(clYellow);

Line (100,200,300,200);

Line (200,100,200,300);

Line (100,100,300,300);

Line (100,300,300,100);

SetBrushColor(clYellow);

Circle(200,200,50)

end

end.

Объяснение:

Вводим температуру

Если t <= 0 рисуем снежинку, иначе (если t > 0) рисуем солнышко

Приложения:

oreshek2222: Спасибо большое ❤️
makmutaziza: Можешь помочь, если не сложно с информатикой?
в моем аккаунте в разделе вопросы. Умоляю!
Новые вопросы