Информатика, вопрос задал ool4ik , 10 лет назад

составьте программу, которая заполняет массив b [1..8] случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с четными значениями.

 

помогитееееееее 

Ответы на вопрос

Ответил DontStopBelievin
0

var
  a: array[1..10] of integer; //Массив целочисленных элементов а
  i, n: integer; //n - количество элементов, равных 1
begin
  n:= 0; //Обнуляем счетчик
  write('Исходный массив: ');
  for i:= 1 to 10 do {Заполняем массив случайными элементами от 1 до 10, распечатываем его и считаем количество элементов, равных 1}
  begin
  a[i]:= random(3);
  write(a[i], ' ');
  if a[i] = 1 then n:= n + 1;
  end;
  writeln;
  writeln('Количество элементов, равных 1: ', n);
end.

Новые вопросы