составьте программу,которая заполняет массив b[1..15] случайными целыми числами в диапазоне от 1 до 20 и выводит тройки элементов,упорядоченные строго по возрастанию.
Срочно!!!!!!!!!11
Ответы на вопрос
Ответил Nobunaga
0
//Это экспериментальное решение, не воспринимайте всерьёз
var ar:array[1..15] of integer;
i:integer;
begin;
var i1:=1;
while i1<=15 do
begin;
var ar1:=ArrRandomInteger(4,1,20);
sort(ar1);
ar[i1]:=ar1[1];
ar[i1+1]:=ar1[2];
ar[i1+2]:=ar1[3];
writeln(ar1[1]:4,ar1[2]:4,ar1[3]:4);
i1:=i1+3;
end;
writeln('Final array:');
for i:=1 to 15 do
write(ar[i]:4);
end.
var ar:array[1..15] of integer;
i:integer;
begin;
var i1:=1;
while i1<=15 do
begin;
var ar1:=ArrRandomInteger(4,1,20);
sort(ar1);
ar[i1]:=ar1[1];
ar[i1+1]:=ar1[2];
ar[i1+2]:=ar1[3];
writeln(ar1[1]:4,ar1[2]:4,ar1[3]:4);
i1:=i1+3;
end;
writeln('Final array:');
for i:=1 to 15 do
write(ar[i]:4);
end.
Ответил Антон5425
0
Program gj;
Var a: array [1..15] of integer;
i:integer ;
Begin
For i:=1 to 15 do
a[i]:=random(20)+1;
writeln('Исходный массив:');
For i:=1 to 15 do
write(a[i], ' ');
writeln;
For i:=2 to 15 do
if (a[i]>a[i-1])and(a[i+1]>a[i])and(a[i+1]>a[i-1])
then begin
writeln(a[i-1],' ',a[i],' ',a[i+1]);
end;
end.
Var a: array [1..15] of integer;
i:integer ;
Begin
For i:=1 to 15 do
a[i]:=random(20)+1;
writeln('Исходный массив:');
For i:=1 to 15 do
write(a[i], ' ');
writeln;
For i:=2 to 15 do
if (a[i]>a[i-1])and(a[i+1]>a[i])and(a[i+1]>a[i-1])
then begin
writeln(a[i-1],' ',a[i],' ',a[i+1]);
end;
end.
Ответил Антон5425
0
в принципе получилось но пишет ошибку времени исполнения...
Ответил Антон5425
0
правильно?
Ответил Nobunaga
0
Вот, намного более упрощённая версия.
Ответил Антон5425
0
спасибо!!!
Новые вопросы