Информатика, вопрос задал ford13 , 7 лет назад

Составьте программу которая заполняет массив а от 1 до 10 случайными целыми числами в диапазоне от 0 до 10 и находит сумму минимального и максимального элементов массива

Ответы на вопрос

Ответил FANTSCR1N
0

program fantscrin;


 const n = 10;


 var a: array [1..n] of integer;


     i,min,max:integer;


Begin


 for i:=1 to n do


   a[i]:= random(10)+1;


 for i:=1 to n do


   write(a[i], '  ');


   


 min:=a[1];


 for i:=1 to n do


   if (a[i]<min) then min:=a[i];


 


 max:=a[1];


 for i:=1 to n do


   if (a[i]>max) then max:=a[i];


 


   


 writeln('');


 writeln(min+max);


End.

Новые вопросы