Информатика, вопрос задал kitnaltastas , 1 год назад

Составьте программу, которая заполняет массив А[1..19] случайными целыми числами в диапазоне от -10 до 12 находит произведение элементов массива, кроме минимального. Использовать пример приведнный в фотографии.ДАЮ 100 БАЛЛОВ!!!​

Приложения:

Ответы на вопрос

Ответил salpsx
0

Ответ: 1 ответ человека написан на языке Python, это говорит о том что человек не читает задание, проявляя неуважение к тебе, дак еще не умеет думать своими мозгами, так как код скопирован с ИИ, жду за свой ответ корону, осталась 1 д главного мозга.

Код:
program CalculateProduct;

var

 A: array [1..19] of integer;

 i, min, k, product: integer;

begin

 for i := 1 to 19 do A[i] := random(23) - 10;

 min := A[1];

 for i := 2 to 19 do if A[i] < min then min := A[i];

 product := 1;

 k := 0;

 for i := 1 to 19 do

   if A[i] <> min then product := product * A[i] else k := k + 1;

 writeln('Массив A:');

 for i := 1 to 19 do write(A[i], ' ');

 writeln;

 writeln('Минимальное значение в массиве: ', min);

 writeln('Произведение элементов массива, кроме минимального: ', product);

 writeln('Минимальное значение встречается ', k, ' раз(а)');

end.


kitnaltastas: спасибо тебе большое, конечно же поставил корону, очень благодарен тебе
Новые вопросы