Информатика, вопрос задал Gumanitariy001 , 8 лет назад

составьте программу, которая выводит все делители натурального числа N (в паскале)

Ответы на вопрос

Ответил petyaGavrikov
0
var n,i:integer;
begin
write('n = ');
readln(n);
writeln('Делители:');
for i:=1 to n div 2 do
 if n mod i = 0 then write(i,' ');
writeln(n);
end.

Пример:
n = 24
Делители:
1 2 3 4 6 8 12 24
Новые вопросы