Информатика, вопрос задал джигурда8 , 2 года назад

составьте программу которая выводит только те числа котрые делятся на 7

Ответы на вопрос

Ответил Hingenburg
2
Возможно нерационально но, пусть. Сначала вы вводите количество чисел, потом сами числа. Если число делится на 7 - то будет соответствующая строка, после чего будет предложено ввести новое число; Если нет, то будет предложено ввести новое число.
program cv;
var
a,i,chislo:integer;
begin
writeln ('Введите количество чисел');
readln (a);
for i:=1 to a do
begin
writeln ('Введите число');
readln (chislo);
if (chislo mod 7=0) then writeln ('Число ',chislo,' делится на 7.')
end;
end.
Новые вопросы