Составьте программу которая выводит на печать все двузначные числа,которые делятся на сумму своих цифр
Ответы на вопрос
Ответил petyaGavrikov
0
var i1,i2:integer;
begin
for i1:=1 to 9 do
for i2:=0 to 9 do
if (i1*10+i2) mod (i1+i2) = 0 then
write(i1*10+i2,' ');
writeln;
end.
Результат:
10 12 18 20 21 24 27 30 36 40 42 45 48 50 54 60 63 70 72 80 81 84 90
begin
for i1:=1 to 9 do
for i2:=0 to 9 do
if (i1*10+i2) mod (i1+i2) = 0 then
write(i1*10+i2,' ');
writeln;
end.
Результат:
10 12 18 20 21 24 27 30 36 40 42 45 48 50 54 60 63 70 72 80 81 84 90
Новые вопросы