Информатика, вопрос задал Yuliksan , 10 лет назад

Составьте программу, которая выполняет сравнение двух введенных с клавиатуры символов и выводит их на экран в порядке возрастания.

Ответы на вопрос

Ответил varscat
0

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
    char a, b;

    cout << "Enter two characters: ";
    cin >> a >> b;

    if(a > b)
    {
        cout << b << ' ' << a << endl;
    }
    else
        cout << a << ' ' << b << endl;

   return 0;
}

 

Если сравнивать заглавную и прописную, то прописная будет выводиться после заглавной(из-за расположения в таблице ASCII)

Приложения:
Новые вопросы