Информатика, вопрос задал mstserkovskaya , 8 лет назад

Составьте программу,которая выполняет массив а(1..10) случайными целыми числами в диапазоне от 1 до 10,затем меняет местами первый элемент со вторым,третий с четвертым и т.д.
Выведите на экран исходный и полученный массивы.

Ответы на вопрос

Ответил BrightOne
0
program swap;
const
  N = 10;
var
  a: array [1..N] of integer;
  i, temp: integer;
begin
  randomize;
  writeln('исходный массив: ');
  for i := 1 to N do
    begin
      a[i] := Random(10);
      write(a[i], ' ');
    end;
  writeln;
  i := 1;
  while i <= 9 do
    begin
      temp := a[i];
      a[i] := a[i+1];
      a[i+1] := temp;
      i := i + 2;
    end;
  writeln('полученный массив: ');
  for i := 1 to N do
      write(a[i], ' ');
end.

Новые вопросы