Составьте программу,которая вводит трехзначное число и выводит число, образованное при перестановке цифр в обратном порядке (например:123-321). В Паскале. Помогите пожалуйста! Спасибо заранее!
Ответы на вопрос
Ответил Аноним
0
var
a:longint;
s:string;
i:integer;
begin
writeln('Введите целое положительное число');
readln(a);
Str(a,s);
write('Результат: ');
for i:= length(s) downto 1 do
write(s[i]);
writeln
end.
Тестовый пример:
Введите целое положительное число
1234567890
Результат: 0987654321
a:longint;
s:string;
i:integer;
begin
writeln('Введите целое положительное число');
readln(a);
Str(a,s);
write('Результат: ');
for i:= length(s) downto 1 do
write(s[i]);
writeln
end.
Тестовый пример:
Введите целое положительное число
1234567890
Результат: 0987654321
Новые вопросы
Математика,
2 года назад
Алгебра,
2 года назад
Алгебра,
9 лет назад
Геометрия,
9 лет назад
Химия,
10 лет назад