Составьте программу которая возводит число X в восьмую степень.
Даю 40 очков.
Ответы на вопрос
Ответил denisrybakov
0
var a:integer;
a:=strtofloat(edit1.text);
a:=a*а*а*а*а*а*а*а;
label1.text:= floattostr(a);
a:=strtofloat(edit1.text);
a:=a*а*а*а*а*а*а*а;
label1.text:= floattostr(a);
Ответил Аноним
0
Огрызок из Дельфи/Лазаруса ?
Ответил denisrybakov
0
делфи , почему ты решил что это отгрызок?
Ответил Аноним
0
Огрызок потому, что есть ссылки на поля Edit и Label, и нет кода форма, в котором прописывается этот текст. Т.е. нельзя просто открыть тот же Дельфи, всунуть в него эти 4 строки и запустить.
Ответил Аноним
0
x⁸ = ( (x²)² )²
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!
begin
var x8:=Sqr(Sqr(Sqr(ReadReal('x='))));
Writeln('x^8=',x8)
end.
Пример
x= 3.17
x^8=10197.0394089246
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!
begin
var x8:=Sqr(Sqr(Sqr(ReadReal('x='))));
Writeln('x^8=',x8)
end.
Пример
x= 3.17
x^8=10197.0394089246
Новые вопросы
Геометрия,
2 года назад
Информатика,
2 года назад
Математика,
8 лет назад
Литература,
8 лет назад
Математика,
9 лет назад