Составьте программу, которая в первую строку выводит названия зимних месяцев, во вторую - весенних, в третью строку - летних и в четвертую строку - названия осенних месяцев.
Ответы на вопрос
#include <iostream>
#include <vector>
using namespace std;
struct Year{
vector<string> winter = {"December", "January", "February"},
spring = {"March", "April", "May"},
summer = {"June", "July", "August"},
autumn = {"September", "October", "November"};
};
void printWinter(Year &year_){
for(auto &i: year_.winter)
cout << i << " ";
cout << "\n";
}
void printSpring(Year &year_){
for(auto &i: year_.spring)
cout << i << " ";
cout << "\n";
}
void printSummer(Year &year_){
for(auto &i: year_.summer)
cout << i << " ";
cout << "\n";
}
void printAutumn(Year &year_){
for(auto &i: year_.autumn)
cout << i << " ";
cout << "\n";
}
signed main() {
Year y;
printWinter(y);
printSpring(y);
printSummer(y);
printAutumn(y);
}