составьте программу, которая позволяет заменить в строке слово мама на слово папа
Ответы на вопрос
Ответил CrazyCoder
0
var //Объявляем переменные
i:integer;
s:string;
begin // Начало работы блока
readln(s); // В переменную S записываем введенную строку
i := Pos('мама', s); // В переменную i записываем количество символов до данного слова
if i > 0 then //Если количество символов больше нуля тогда
begin
Delete(s, i, 4); // Удаляем из веденной строки (Переменная S), слово мама, содержащие 4 символа
Insert('папа', s, i); // Заменяем словом Папа
end; //Конец
writeln(s); //Выводим на экран полученный текст
end.
i:integer;
s:string;
begin // Начало работы блока
readln(s); // В переменную S записываем введенную строку
i := Pos('мама', s); // В переменную i записываем количество символов до данного слова
if i > 0 then //Если количество символов больше нуля тогда
begin
Delete(s, i, 4); // Удаляем из веденной строки (Переменная S), слово мама, содержащие 4 символа
Insert('папа', s, i); // Заменяем словом Папа
end; //Конец
writeln(s); //Выводим на экран полученный текст
end.
Ответил Аноним
0
Два вопроса. 1) Если написано не мама", а "Мама"? 2) Если фраза такова: "Мама Васи испекла пирожки, а мама Лены сделала салаты" ?
Ответил Аноним
0
Или тогда "кодер" уже не "крэйзи"? )))
Новые вопросы