Информатика, вопрос задал hqqqj , 6 лет назад

составьте программу которая подсчитывает сумму и произведение цифр введеного трехзначного числа
составить алгоритм в паскале!

Ответы на вопрос

Ответил valgrisa
1

Ответ:

program z;

var a,c1,c2,c3,s,p:integer;

begin

read(a);

c1:=a div 100;

c2:=a div 10 mod 10;

c3:=a mod 10;

s:=c1+c2+c3;

p:=c1*c2*c3;

write(s,' ',p)

end.


hqqqj: можете помочь с еще одной задачей?
valgrisa: Доброе утро! Зависит от задачи )
hqqqj: написать программу которая меняет местами первую и последнюю цифру в четырехзначном числе, тоже в паскале
valgrisa: program z;
var a:integer;
begin
read(a);
a:=a mod 10 * 1000+ a mod 1000 div 10 * 10 + a div 1000;
write(a)
end.
hqqqj: извините, а вы ещё помочь не сможете? там одну-две задачи похожие решить, можете посмотреть я залила новый вопрос
Новые вопросы