Составьте программу, которая по номеру семестра печатает курс, к которому относится введенный семестр (1 и 2 семестр – 1 курс, 3 и 4 семестр – 2 курс и т. д.) 3) Для каких из приведённых чисел ложно высказывание: НЕ (число > 50) ИЛИ (число чётное)? Выберите правильные ответы: 123 50 9 8 97
Ответы на вопрос
Ответил DexelGamer
0
1.
Код (Pascal)
var
x: integer;
begin
read(x);
writeln((x + 1) div 2);
end.
--------------------
Прикреплён во вложениях.
2.
Давай "перевернём" условие с "НЕ" для понимания:
НЕ (число > 50) = (число <= 50)
- Рассмотрим число 123. Для него не выполняется условие НЕ (123 > 50) и не выполняется условие (123 чётное). Высказывание ложно, число подходит.
- Рассмотрим число 50. Для него выполняется условие НЕ (50 > 50). Высказывание истинно, число не подходит.
- Рассмотрим число 9. Для него выполняется условие НЕ (9 > 50). Высказывание истинно, число не подходит.
- Рассмотрим число 8. Для него выполняется условие НЕ (8 > 50). Высказывание истинно, число не подходит.
- Рассмотрим число 97. Для него не выполняется условие НЕ (97 > 50) и не выполняется условие (97 чётное). Высказывание ложно, число подходит.
Ответ: 123 97
Приложения:
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад
Биология,
7 лет назад
Алгебра,
9 лет назад