Составьте программу,которая определяет,является ли сумма цифр введенного целого четырехзначного числа четным числом.
Ответы на вопрос
Ответил moboqe
0
uses crt;
var x,a,b,c,d:integer;
begin
readln(x);
a:=x mod 10;
b:=x div 10 mod 10;
c:=x div 1000;
d:=x div 100 mod 10;
if((a+b+c+d) mod 2=0) then writeln ('Сумма цифр числа чётная')
else writeln('Сумма цифр числа нечётная');
end.
var x,a,b,c,d:integer;
begin
readln(x);
a:=x mod 10;
b:=x div 10 mod 10;
c:=x div 1000;
d:=x div 100 mod 10;
if((a+b+c+d) mod 2=0) then writeln ('Сумма цифр числа чётная')
else writeln('Сумма цифр числа нечётная');
end.
Ответил Аноним
0
a:=x mod 10;
b:=x div 10 mod 10;
c:=x div 1000;
d:=x div 100 mod 10;
b:=x div 10 mod 10;
c:=x div 1000;
d:=x div 100 mod 10;
Ответил moboqe
0
спасибо за подсказку
Новые вопросы
Геометрия,
2 года назад
Математика,
8 лет назад
Математика,
8 лет назад
Литература,
9 лет назад
Алгебра,
9 лет назад