Информатика, вопрос задал dankoa1235 , 9 лет назад

Составьте программу которая определяет сколько слагаемых должна быть в сумме 1 + 2 + 3 + 4 +..., чтобы сумма оказалась а) больше 20 б) больше заданного числа n. результат- количество слагаемых- выведите на экран. Составьте блок-схемы

Ответы на вопрос

Ответил антагонист
0
a)
var sum,col:integer;
beginsum:=0;
col:=1;
while (sum<=20) do begin
sum:=sum+col;
col:=col+1;
end;
write('количество слагаемых больше 20 = ',col-1);
end.
b)
var n,sum,col:integer;
begin
read(n);
sum:=0;
col:=1;
while (sum<=n) do begin
sum:=sum+col;
col:=col+1;
end;
write('количество слагаемых больше ',n,' = ',col-1);
end.
Новые вопросы