Информатика, вопрос задал nnusratov48 , 1 год назад

Составьте программу, которая определяет, сколько положительных, сколько отрицательных, сколько нулей присутствует среди 5 заданных чисел.C++

Ответы на вопрос

Ответил antarctica123
0

Відповідь:

#include <iostream>

using namespace std;

int main()

{

   int num, pos = 0, neg = 0, zero = 0;

   for (int i = 0; i < 5; i++) {

       cout << "Введите число: ";

       cin >> num;

       if (num > 0)

           pos++;

       else if (num < 0)

           neg++;

       else

           zero++;

   }

   cout << "Количество положительных чисел: " << pos << endl;

   cout << "Количество отрицательных чисел: " << neg << endl;

   cout << "Количество нулей: " << zero << endl;

   return 0;

}

Пояснення:

Новые вопросы