составьте программу которая определяет какое из трёх наибольшее. Создать программу на языке Си, помогите пожалуйста
Ответы на вопрос
#include <stdio.h>
int main()
{
int a, b, c, max;
char s;
scanf("%d%d%d", &a, &b, &c);
max = a;
s = '1';
if (b > max)
{
max = b;
s = '2';
}
if (c > max) s = '3';
printf("%c", s);
return 0;
}
Выводится номер в порядке ввода наибольшего числа, т.е. 1, 2 или 3.
Ответ:
#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <stdio.h>
int main()
{
float a, b, c;
setlocale(LC_ALL, "Russian");
printf("Введите три числа: ");
scanf("%f %f %f", &a, &b, &c);
if (a > b && a > c)
printf("Наибольшее число = %f", a);
else if (b > a && b > c)
printf("Наибольшее число = %f", b);
else if (c > a && c > b)
printf("Наибольшее число = %f", c);
else
printf("Наибольшее значение имеют несколько чисел");
}