Информатика, вопрос задал kshvabauer , 8 лет назад

Составьте программу, которая находит произведение цифр заданного четырёхзначного числа . В Pascal ABC.ru

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1338 от 16.11.2016
begin
  var n:=ReadInteger('Введите четырехзначное натуральное число:');
  var p:=1;
  while n>0 do begin
    p:=p*(n mod 10);
    n:=n div 10
    end;
  Writeln('Произведение цифр числа равно ',p)
end.
Новые вопросы