Информатика, вопрос задал Аноним , 2 года назад

Составьте программу, которая находит первую позицию пробела в строке s, А ЗАТЕМ ПРОВЕРЯЕТ, есть ли еще пробелы в данной строке. Строка вводится с клавиатуры.
паскальабс


vimmortal2: pascal?

Ответы на вопрос

Ответил vimmortal2
4

Ответ:

var

s: string;

i,dop: integer;

begin

writeln('Введите строку:');

readln(s);

writeln(pos(' ', s));

dop := Length(s);

for i := 1 to dop do

if s[i]=' ' then

write(' ')

end.

Если нужно вывести ВСЕ пробелы, то:

dop := Length(s);

for i := 1 to dop do

if s[i]=' ' then

write(' ')

end.

Проверка на наличие 2+ пробелов (размещать в конце (перед end.)):

if i > 3 then

 write('Пробелы ещё есть')

else

 writeln('Пробелов больше нет');


Аноним: там надо еще он проверял есть ли еще пробелы
vimmortal2: ну вон снизу проверка, вы же не писали, что нужно вывести ещё пробелы
vimmortal2: я изменил, если надо все пробелы вывести
Аноним: оно высвечивает на каком месте есть пробел , а надо чтобы было есть ли еще пробелы помимо этого или нету
vimmortal2: изменил
Новые вопросы
Геометрия, 2 года назад