Информатика, вопрос задал taramykintone228 , 1 год назад

Составьте программу, которая из слов «финал», «урок», «турист», «балет», «окно». «линия» составляет и выводит слова «футбол».


moonflower941: python
Copy code
from itertools import permutations#
Список из исходных слов
words = ["финал", "урок", "турист", "балет", "окно"]
# Искомое слово
target_word = "футбол"
# Перебор всех возможных комбинаций букв из исходных слов
all_combinations = set()

Ответы на вопрос

Ответил moonflower941
0

Вот пример программы на Python, которая составляет и выводит слова из предоставленных букв, таким образом, чтобы слово "футбол" также содержалось в итоговом списке:

python

Copy code

from itertools import permutations

# Список из исходных слов

words = ["финал", "урок", "турист", "балет", "окно"]

# Искомое слово

target_word = "футбол"

# Перебор всех возможных комбинаций букв из исходных слов

all_combinations = set()

for word in words:

   all_combinations.update([''.join(p) for p in permutations(word)])

# Поиск слов, содержащих слово "футбол"

result_words = [word for word in all_combinations if target_word in word]

# Вывод результатов

print("Слова, в которых есть 'футбол':")

print(result_words)

Новые вопросы