Составьте программу, которая формирует массив из двадцати случайных целыъ от -15 до 15 и уменьшает в 3 раза числа, кратные 3, а остальные увеличивает в 2 раза
Ответы на вопрос
Ответил 13nisa13
0
var a:array[1..20] of integer;
i: integer;
begin
write(' Исходный массив: ');
for i:=1 to 20 do
begin
a[i]:=random(31)-15;
write (a[i]:3,' ')
end;
writeln;
write('Преобразованый массив: ');
for i:=1 to 20 do
begin
if (a[i] mod 3 = 0) then a[i]:=a[i] div 3
else a[i]:= a[i]*2;
write (a[i]:3,' ')
end
end.
Новые вопросы