Составте программу, которая формирует массив из 5 целых чисел,элементы массива вводятся вручную с клавиатуры. Найдите максимальный элемент в массиве. ответ вывести в формате "Мах=".
Ответы на вопрос
Ответил pacixor
0
//Pascal
var
A: array[1..5] of integer;
i: byte;
MAX: integer;
begin
writeln('Заполнение массива.');
for i := 1 to 5 do
begin
write('A[',i,'] = '); readln(A[i]);
end;
MAX := A[1];
for i := 1 to 5 do
begin
if A[i] > MAX then MAX := A[i];
write(A[i]:4);
end;
writeln;
writeln('Максимальный элемент в массиве = ', MAX);
readln;
end.
var
A: array[1..5] of integer;
i: byte;
MAX: integer;
begin
writeln('Заполнение массива.');
for i := 1 to 5 do
begin
write('A[',i,'] = '); readln(A[i]);
end;
MAX := A[1];
for i := 1 to 5 do
begin
if A[i] > MAX then MAX := A[i];
write(A[i]:4);
end;
writeln;
writeln('Максимальный элемент в массиве = ', MAX);
readln;
end.
Новые вопросы
Информатика,
2 года назад
Геометрия,
2 года назад
Физика,
8 лет назад
Физика,
9 лет назад
Математика,
9 лет назад