Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет сумму чисел, кратных 3
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1336 от 14.11.2016
begin
var a:=ArrRandom(40,0,20); a.Println;
Writeln('s=',a.Where(i->i mod 3=0).Sum)
end.
Пример
17 10 9 6 7 11 8 2 10 5 9 17 13 1 18 19 4 12 9 9 17 20 6 1 10 18 18 13 8 13 20 8 15 2 19 20 20 0 20 15
s=144
begin
var a:=ArrRandom(40,0,20); a.Println;
Writeln('s=',a.Where(i->i mod 3=0).Sum)
end.
Пример
17 10 9 6 7 11 8 2 10 5 9 17 13 1 18 19 4 12 9 9 17 20 6 1 10 18 18 13 8 13 20 8 15 2 19 20 20 0 20 15
s=144
Новые вопросы
География,
2 года назад
География,
2 года назад
Физика,
8 лет назад
Математика,
8 лет назад
Химия,
9 лет назад