Составьте программу которая формирует массив из 10 случайных чисел в диапазоне от 1 до 10 и вычисляет произведения элементов массива с нечестными значениями.
На экран выводится исходный массив, массив с нечестными значениями и произведение.
Ответы на вопрос
Ответил FANTSCR1N
0
program fantscrin;
const n = 10;
var a: array [1..n] of integer;
i,s:integer;
Begin
for i:=1 to n do
a[i]:= random(11)+1;
for i:=1 to n do
write(a[i], ' ');
p:=1;
for i:=1 to n do
if (i mod 2 <> 0) then
begin
p:=p*a[i];
write(a[i], ' ');
end;
writeln('');
writeln('Произведение = ',p);
End.
Новые вопросы