Информатика, вопрос задал Ромашка10 , 10 лет назад

составьте программу которая а)выполняет операцию сцепления трех введенных с клавиатуры символов б)выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран. например 'a'<'б', 'д'='д, 'я'>'ы' в) выполняет сравнение двух введенных с клавиатуры символов и выводит их на экран в порядке вохрастания их кодов

Ответы на вопрос

Ответил sansanic
0

а), б)

var a, b, c: char;

begin

  writeln('Введите 3 символа');

  readln(a, b, c);

  writeln('Результат сцепления: ', a+b+c);

  if a>b then writeln(a,'>', b);

  if a>c then writeln(a,'>', c);

  if a=b then writeln(a, '=', b);

  if a=c then writeln(a, '=', c);

  if a<b then writeln(a, '<', b);

  if a<c then writeln(a, '<', c);

  if b>c then writeln(b, '>', c);

  if b<c then writeln(b, '<', c);

end.

в)

var a, b: char;

begin

  writeln('Введите 2 символа');

  readln(a, b);

  if a>b then writeln(b,'  ', a);

  if a<b then writeln(a,'  ', b);

  if a=b then writeln(a,'  ', b);

end.

  

   

Новые вопросы